Why is Conqu not available for my device in the Android market?

Conqu requires a minimum Android version of 2.2 (aka Froyo) with a processor AMR 7 or above.

If your device is running that version, it is possible that the device type itself is excluded from the supported devices (only certain Dell tablets are excluded). When in doubt, send us a quick message in the forums with your device information, including Android version.

If you believe that your phone meets the above requirements, you can try installing Conqu directly by downloading the apk from: http://conqu.com/downloads/android_market/phone/Conqu.apk

Feedback and Knowledge Base